I am trying to use a repository being served at my work, by me. If I:

git ls-remote

It shows the branches that I expect, e.g.:

... refs/remotes/floop

git branch -a shows:

* master
  remotes/origin/HEAD -> origin/master

git branch -r show:

origin/HEAD -> origin/master

This produces an error message:

git checkout  -b noo origin/floop

Fatal: Cannot update paths and switch to branch 'noo' at the same time.

So, after that I've tried things I've read about but don't understand, like:

git remote update
git fetch

I get the same error message when trying to checkout the branch.

git remote add woof https://example.com/arf.git
git fetch woof
git checkout -b noo woo/floop

Produces the same error message.

git branch -a

now also shows


and nothing else new.

Can you tell what the problem is?

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to