Hi,
 
I found some discussions with a similar problem, but did not find a 
solution.
I have tried
DATE_STAMP=$(date +%Y%m%d%H%M)
LOG=/var/tmp/git.log
echo "checkout $DATE_STAMP" >>$LOG
cd /var/tmp/test2_clone
unset GIT_INDEX_FILE
export GIT_WORK_TREE=/var/tmp/test2_clone
export GIT_DIR=/data/git/test2.git
git fetch origin
git reset --hard origin/master
git clean -f -d
but I still get an error
git push
Enter passphrase for key '/home/user1/.ssh/id_rsa': 
Counting objects: 5, done.
Delta compression using up to 32 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (3/3), 290 bytes, done.
Total 3 (delta 0), reused 0 (delta 0)
remote: /var/tmp/test2_clone
remote: fatal: 'origin' does not appear to be a git repository
remote: fatal: The remote end hung up unexpectedly
remote: fatal: ambiguous argument 'origin/master': unknown revision or path 
not in the working tree.
remote: Use '--' to separate paths from revisions
remote: Removing test2.txt
remote: Removing text1.txt
To git@rh6-puppet-master:/data/git/test2.git
   94875ac..7abfb5d  master -> master
 
Best regards,
Andreas

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to