I have got a virtual private server with nginx Virtual Hosts setup (Server 

I've installed Git and got my ssh keys authenticated with GitHub.

I have my website running in


I tried to run:

git clone g...@github.com:example/example.co.uk.git

to pull my files on GitHub to the /public_html/ directory but I get the 

fatal: could not create work tree dir 'example.com'.: Permission denied

I've followed this tutorial including the same issue he has mentioned on 
the page, but it still won't work:

I have tried creating a directory in /public_html/ and that works correctly.

I then tried running sudo git clone g...@github.com:exam .... etc. and got 
the error:

Permission denied (publickey).

fatal: The remote end hung up unexpectedly

I'm completely new to this, so your help would be much appreciated!

Thanks Dave

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to