Hello Konstantin,

Sorry hit enter too fast. and we also tried start from beginning reintall
the gitbash and git extensions and now when we try to clone the
repositories, and after we insert the private key and try to browse the
branch, and it just hangin there and never pull out any branches for us to
choose, but git bash is works good on clone, so just want to check if you
have any clue regards this?


On Mon, Dec 9, 2013 at 2:34 PM, lingfei ouyang <oylf1...@gmail.com> wrote:

> Hello Konstantin,
> We had tried all three links but no lucks, and also we had tried
> re-install/config the git/git-extensions, and it still throw us the errors,
> so
> On Wed, Nov 13, 2013 at 7:08 AM, Konstantin Khomoutov <
> flatw...@users.sourceforge.net> wrote:
>> On Tue, 12 Nov 2013 12:08:26 -0500
>> lingfei ouyang <oylf1...@gmail.com> wrote:
>> > When using Git bash is works good, and Protocal is SSH.
>> Googling for the correct phrase,
>> "fatal: protocol error: bad line length character"
>> turns up a number of revelant discussions, for instance, [1], [2],
>> [3] and so on.  They all boil down to the single cause for an error
>> you're facing: when an SSH client spawned by Git connects to the remote
>> SSH server to spawn there a remote Git process, something gets executed
>> before the remote Git process is run, and that "something" prints
>> messages to its standard output stream.  Since the local and remote Git
>> processes communicate via their standard input and output streams
>> (interconnected and tunneled by the SSH session), the printed junk is
>> passed by SSH to the local Git client which then attempts to interpret
>> it as a Git protocol exchange, and obviously fails.
>> I don't know your server-side setup but the most common cause appears
>> to be an initialization script for a non-login shell.
>> In more detal: after you log in *interactively* via SSH, the SSH server
>> spawns your default shell on the server in login mode, and you then
>> work with it.  If you log in via SSH non-interactively (that's what Git
>> does), the SSH server spawns your default shell in non-login mode and
>> passes it a command to execute, which the client submitted.
>> For instance, if your account has bash as its default shell, in login
>> mode, the ~/.bash_profile startup script is typically executed, and in
>> non-login mode, ~/.bashrc is executed.  Supposedly your ~/.bashrc (or a
>> matching file for your shell) contains/calls some code which prints
>> something.
>> As to *why* you see this error -- I don't know.  Either you're using
>> different user accounts when pushing from Git bash and Git Extensions
>> or you're pushing to different servers.  In either case I think you now
>> have enough clue to try to debug the problem further down.
>> 1. http://stackoverflow.com/q/8170436/720999
>> 2. http://stackoverflow.com/q/17296348/720999
>> 3. http://stackoverflow.com/q/3224340/720999

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to