I am git noob so please be kind...

We are trying to use git as part of our product, and have run into a 
problem with Red Had 6 systems. Since our IT department only lets 
developers use RH5.6 systems we didn't find out about this until pretty 
late in the project. 

The issue is that git 1.8.3 has a dependency on libcrypto.so.6 and 
libssl.so.6. Or more precisely, git-remote-http seems to have dependencies 
on these libraries. On our RH5.6 boxes, not a problem as they are found in 
/lib64. On RH6 (kernel version 2.6.32-431), big problem, they aren't found 
at all when I run git, or do "ldd git-remote-http" to check the 
dependencies. As best I can tell, these libraries are not included in the 
RH6 standard installation. Now I could beg our IT to install the necessary 
RPMs on our RH6 boxes (and yes it will take considerable groveling and 
begging) but it doesn't seem that will solve the problem when our s/w is 
installed by RH6 customers. They will presumably see the same:

git-remote-help: error while loading shared libraries: libssl.so.6

error that I see.

I've tried building git with SSL disabled by running configure with the 
--with-openssl=no option. That results in a git binary that doesn't have 
the dependency on libcrypto, but does nothing about the dependencies in 

Any ideas?



You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to