On Sunday, April 13, 2014 6:19:17 PM UTC+2, dunno wrote:
>
> I have a "Main" project in which I splitted a few sub directories with the 
> `subtree split` command. I've made some changes to one of the splitted sub 
> directories and now I'd like to push that to their own upstream 
> repositories.
>
> Normally I'd do that like this (this has worked before):
>
>     $ git subtree push --prefix=src/Shared/Util/ 
> https://github.com/user/util.git master
>
> But when I run this command it says:
>
>     Everything up-to-date
>
> But it's not... I made all sorts of changes to files. I even added new 
> ones. And those aren't there yet in my upstream repo.
>
> Then why is Git telling me that everything is up to date when it's not? 
> How can I fix this problem?
>

I'm not too familiar with git subtree, but problems like these often arise 
due to a false understanding of which repository has what state.

I find it very helpful in such situations to have a good look at these:

git fetch # sync remotes
gitk --all # visually study the state in local and remote branchs 
git --all --log --decorate --oneline # ascii-art version of the gitk 
command above
git remote -vv # what remote branches am I tracking?
git remote show origin # what's going on in remote named origin?

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to