On Tuesday, 9 September 2014 10:48:23 UTC+2, jo...@norricorp.f9.co.uk wrote:
>
> Hi,
> I have run ssh-keygen to generate a rsa key which I pasted to the 
> authorized_keys file fore the git user on the git server. And all works, I 
> can run git pull and push commands without being asked for a password.
> But if I run "ssh git...@gitserver <javascript:> command" then I am asked 
> for the password. ssh is in git\bin.
> I tried creating a ssh key with putty  and adding that to the auth_keys 
> file as well but makes no difference.
> Any ideas what I am doing wrong / have not understood?
> Regards,
> John
>

Sounds more like a SSH configuration issue rather than a Git issue, so this 
doesn't belong to this group. Look for groups / forums about using SSH in 
your environment (you mentioned PuTTY so I guess you're using Windows and 
that tools like MySysGit, Cygwin or others are involved), your issue might 
be specific to those.

That said, running your ssh command with the *-v* option *(verbose mode)* 
will give you details on what's happening when you try to connect, and 
explicitely specifying an identity file to use with the *-i* option could 
help you spot if your environment can't find your private key file 
*(~/.ssh/id_rsa 
I guess)* for some reason.

-- 
You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to