I wrote about having a stuck server a while back, and now have new 

I have a remote GIT HTTP server at http://git.algoram.com/dvs/
I created it with "git init --bare --group" and then pushed from my 
development system. I serve this with nginx.

After I commit and push a new change, a "git clone" or "git pull" of the 
remote repository won't get it, the remote repository appears to be stuck 
at the previous change from the HTTP side, but I can see the change log 
entry while logged into the system.

If I run "git repack" on the remote server, then "git clone" and "git pull" 
will get the new change, but the remote repository is stuck at that new 
change despite any subsequent pushes, until I repack it again.

So, I have a work-around by running "git repack", but would like to fix the 

Nginx runs as user www-data. I tried to see if this was a permission 
problem by using "su www-data" on the system, and I can still see the 
change log entry.



You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to