From: "Fahad Ashfaque" <>
still don't get it.

Do check each instance of bash separately. Each can have a different virtual root.

I was caught by this just last week on Msysgit (the msys.bat) where that has a different base address to the Git bash version in "C:\program files".

I run /c/path/to/ just fine,.... Its only 'git commit' that is
teleporting me to a different world. So there is NO way I can refer to
folders outside of my repository in a shell script when it is used in
a config param ?

I will try setting the core.editor to the value you suggested.

On Fri, Nov 21, 2014 at 12:48 PM, Philip Oakley <> wrote:
From: "Fahad Ashfaque" <>

I have downloaded the latest git from git-scm on my windows machine.

I am using git on windows, I am having trouble trying to get notepad++
as my commit message editor.

I have created a shell script called which has the following

/c/Program\ Files\ \(x86\)/Notepad++/notepad++.exe -multiInst
-nosession -noPlugin $1

I figured this is how paths are accepted in git-bash

Now I configured core.editor this way

git config --global core.editor /c/path/to/

I simply have (from 'git config -l'):
core.editor='C:/Program Files/Notepad++/notepad++.exe' -multiInst -notabbar
-nosession -noplugin

when I try to commit, using the following command

git commit

I get the following error
$ git commit
error: cannot spawn c:/path/to/ No such file or directory
error: unable to start editor 'c:/dev/tools/cmd/'
Please supply the message using either -m or -F option.

when I run the following command

ls c:/

I get the directory for my repository's root, not C drive's root

When I run the following command through git-bash


It works

but when git commit invokes, it does not.

Here is more of what I found

when 'git commit' launches, it changes /c/path/to/ to

c:/ is not the root of my C drive according to git-bash,

Correct. The "Linux" bash is rooted, _usually_, at the base of your personal 'c:/documents and settings' (or whatever on your Windows version), with the
MS drives under /c/ and /d/ etc. i.e. a load of virtualisation.

use 'pwd -W' to get the true (Windows) path of your current/present working
directory. (I had to ask just a few days ago ;-)

c:/ is root
of my repository because when I run 'ls c:/' I get files from root of
my repository.

I wouldn't have expected that to play nice (confusion between windows and
linux path styles).

so may be if 'git commit' does not change /c/path/to/ to
c:/path/to/, it would work... Or if git-bash does not mount c:/
to /c/path/to/myrepository and keep it to /c it would work too.

Please let me know if you need more info on this

I've also copied in the Git user / Git for Human beings list (for reference)
which can be useful for Windows based issues.



To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

You received this message because you are subscribed to the Google Groups "Git for 
human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to