On Tuesday, January 27, 2015 at 10:50:22 AM UTC+1, Zsolt Ero wrote:
> Git corrupts all repositories, even by calling simple read-only commands 
> (status, etc.), in the following scenario:
> 1. Create or commit to a repo under Git 2.2.2 (system spec: OS X 10.9.5, 
> homebrew latest git)
> 2. Go to the same folder from a Windows computer (Windows 8.1, git version 
> 1.9.4.msysgit.0, HFS+ for Windows 8 Free for accessing the partition)
> 3. By simply reading the branch information in cmder using msysgit, the 
> repo is corrupted.
> This is what it says at the bottom when simply running "git":
> error: object file .git/objects/dd/881c8dff481756ddba39034b7ba3c5cbeb1ec3 
> is empty
> error: object file .git/objects/dd/881c8dff481756ddba39034b7ba3c5cbeb1ec3 
> is empty
> fatal: loose object dd881c8dff481756ddba39034b7ba3c5cbeb1ec3 (stored in 
> .git/objects/dd/881c8dff481756ddba39034b7ba3c5cbeb1ec3) is corrupt
> "git status" also writes the following lines:
> error: object file .git/objects/e8/45566c06f9bf557d35e8292c37cf05d97a9769 
> is empty
> fatal: loose object e845566c06f9bf557d35e8292c37cf05d97a9769 (stored in 
> .git/objects/e8/45566c06f9bf557d35e8292c37cf05d97a9769) is corrupt
> I don't know if it matters that it's a Windows computer, but I can 100% 
> reproduce the issue like this.
> I'll be checking if it's related to the file system driver by making a zip 
> from the clean 2.2.2 repo.
Serious Git bugs should go to the respective mailing list [1].

I just tried recreating this on OSX with Git 2.2.1 (from homebrew). I then 
opened the same repository on a Windows virtual machine (Windows XP on 
VMWare Fusion) with Git 1.9.4. Works fine.

I then tried upgrading to Git 2.2.2, repeating the operation. Still no 

Can you reproduce it when initializing a repo and just committing one file 
in it?

Can you recreate it when moving/copying/cloning the repo to a local NTFS 
disk on Windows?

[1] https://gist.github.com/tfnico/4441562

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to