On Thursday, February 5, 2015 at 12:44:37 AM UTC+1, J66st wrote:
> Adding another snippet to the previous post.
> The failure occurs in the DixiLink2/ directory.
> Then I clone the directory to DixiLink6/ : there everything works fine.
> A directory of tree compare shows not a single difference, in contents nor 
> in attributes.
> (Well, could there be a difference in some alternative stream, this is 
> NTFS.)
> Sorry for the lengthy posts.

I skimmed across your findings, and by the looks of it there is something 
really strange going on.

Am I correct in understanding that zipping and then unzipping the directory 
fixed it in one case?

In another example, you fixed it by renaming the file twice?

How do you effectively reproduce the issue in another folder? Just a simple 
copy of the folder where the problem originated?

Since the problem seems somewhat ephemeral, and goes away when doing some 
simple file operations, I tend to think that this has something to do with 
NTFS. Perhaps Git is getting some kind of cached value from the file system 
when doing diff/status, while you get the actual real contents when 
manually reading the file. Can you recreate the issue on different disk 
(USB stick)? What if it's FAT32 formatted?

Perhaps it would be good to have someone from the Git for Windows mailing 
list see if they recognize this problem.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to