I'm trying to convert RCS history files to a git repository, using 
rcs-fast-import tool.

When I run it with "." – for export all *,v files in current directory, I 
get the following problem:

> git init && rcs-fast-export.rb . | git fast-import && git reset

Reinitialized existing Git repository in 

Preparing commits

rcs-fast-export.rb:698:in `initialize': NoBranchSupport (NoBranchSupport)

from rcs-fast-export.rb:1041:in `new'

from rcs-fast-export.rb:1041:in `block (2 levels) in <main>'

from rcs-fast-export.rb:1039:in `each'

If I run the same command with file name, the file is converted 
successfully. BUT running the same command for next file- give the below 

and 'git clone' shows only the first converted file.

> rcs-fast-export.rb pcs_soc_ftr.c,v | git fast-import && git reset

commit export loop #1

118 to export: 1.1,,,,,,,,,,,,,,,,,,,,,, 18.1,, 19.1,, 2.1,,, 20.1,, 21.1,, 22.1,, 23.1,, 24.1,, 
25.1,, 26.1,, 27.1,, 28.1,, 29.1,, 3.1,,, 30.1,, 31.1,, 32.1,, 33.1,, 34.1,, 35.1,, 36.1,, 
37.1,, 38.1,, 39.1,, 40.1,, 41.1,, 42.1,, 43.1, 

no author found for plguest1

no author found for plgioral



warning: Not updating refs/heads/2.1.1.x (new tip 
e755e54e995076ee3860e5acd21378066958edac does not contain 

warning: Not updating refs/heads/37.1.1.x (new tip 
2a43de0df17ddfda5afdcd57c7e0d23e19cf87de does not contain 


What's the correct command to convert multi-files from RCS to git?


You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to