Hi all, I have a server that only supports the dumbest HTTP push over 
WebDAV. The repository is secured by basic HTTP auth.

I face problems with push when using any other credential helper than netrc.

With netrc helper, pushes succeed.

With e.g. the Windows credential helper or Gnome Keyring helper, all pushes 
fail with errors like:

error: Cannot access URL 
http://martin-pecka.eu/ctyrkazjh/wp-content/themes/skaut/.git/, return code 
fatal: git-http-push failed
error: failed to push some refs to 

It is in no way a wrong credentials problem, since in the attached log you 
can see that the client succeeded downloading at least one protected URL, 
and failed with another one.

I thought the credential helpers should all have the same API, but 
apparently in the logs I see that the netrc helper is somehow "privileged" 
and tried every time.

Tried with Git 2.6.3 on Win 7 64bit and Ubuntu Trusty 64bit. Also tried 
with Git 1.9 on Win 7 64bit. The result's still the same.

Do you have any idea on what's going on? 

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Attachment: manager.log
Description: Binary data

Attachment: netrc.log
Description: Binary data

Reply via email to