Apparently running git config --global http.sslCAPath 
instead of git config --system http.sslCAPath 

fixed the issue

On Thursday, January 14, 2016 at 11:17:08 AM UTC+1, Bison Ravi wrote:
> Hi guys,
> I have setup Git/GitLab on Debian 7.7
> I have configured GitLab for SSL.
> Now i am trying to connect to my Git project with GitGUI for Windows and i 
> receive the following error: 
> fatal: unable to access '
>': SSL certificate 
> problem: self signed certificate
> I have read a couple of posts about that issue and tried this command:
>    1. git config --system http.sslCAPath /etc/gitlab/ssl. The path above 
>    contains the Self-Signed certificate i have created for use with Gitlab. 
>    2. I also copied the crt file to ca-certifcates and ran the below 
>    command to add the CA as Trusted on the Git server
>  cp /etc/gitlab/ssl/remcorpgit01.corp.remarkgroup.local.crt 
> /usr/share/ca-certificates/
>  dpkg-reconfigure ca-certificates
>       3. I have installed the certificate on my local machine (Windows 
> client)  in the Trusted Root Certificate store
> Despite all this i still get the fatal error (even with new projects)
> Any help would be appreciated.
> Thanks.

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to