Background: I used git a little several years ago, never got very 
proficient.  I'm now planning on using it again in writing a piece of 
software, so I'm trying to get up to speed.

Here's my problem:  I created a directory to do my development in, 
downloaded a tar containing the related software that I will add to with my 
development, and created a .git repository in the directory.

I (git) added and committed all the software that I downloaded to the .git 
repository, and then, to further my learning (I thought ;-), I deleted all 
the original software (using, iirc, rm -rf * on the appropriate 
(sub-)directories, anticipating that I would get it all back by checking it 
out (git checkout).

For reference, this is the top level of my directory (before the deletion), 
named sciscint_git (to remind me there is a hidden .git directory in there):

$ ls sciscint_git
scite scintilla .git

(scite and scintilla are subdirectories containing the code)

I've tried a number of variations, but I'm not getting the software (I 
guess git would call it the working tree) back.  Some of the variations 
(all run from within sciscint_git):

git checkout HEAD
git checkout MASTER
git checkout 76641b5

I've also tried those with the -b option.

What am I doing wrong?


1. I"m sure the code is stored in the repository, as du shows something 
like 5.5 MB in .git

2. What I see when I run (most of) those commands is a long list of the 
files that I'd expect to be restored, each prefixed by a D (which I assume 
means deleted).

3.  After the deletion, I didn't do either another add or commit.


You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to