Hello All,

I am having a problem with git on my mac. Yesterday I was completing an 
assignment for a course I am taking where we set up a git workspace and 
imported new settings which changed certain features like $ color. Some of 
the features didn't take, like being able to launch sublime from the 
terminal. I attempted to retrace my steps, but could not figure out what 
was missing. Stupidly, I ended up deleting two files that I shouldn't have, 
which seems to now be causing a huge issue with git and my .bash profile. I 
receive the following error upon logging in:

-bash: /Users/Justin/git-completion.bash: No such file or directory
-bash: /Users/Justin/git-prompt.sh: No such file or directory
-bash: __git_ps1: command not found
Justin ~ $

I believe the problem stems from the missing git-completion.bash and 
git-prompt.sh files. I am not sure about the git_ps1 error. 

I have tried to identify the location of git using 'which git' but I am 
denied, and similarly, I have been denied every way I could think of to 
remove git. I have tried the following commands:

rm -rf /usr/local/git
rm /etc/paths.d/git
rm /etc/manpaths.d/git

sudo port uninstall git

brew uninstall git

None of these commands have been successful. I feel like I am completed 
bricked. Please help!

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to