The packfile is only ~52kb, so its size is probably not an issue.

I successfully ran `git gc` on two other repositories, so the issue is not 

On Monday, June 5, 2023 at 3:48:03 PM UTC-5 Lyndon Gingerich wrote:

> I discovered this problem from investigating the Git console in JetBrains 
> Rider, noticing that it was taking excessively long to create commits. I'm 
> running Git for Windows.
> When I run `git gc`, I get this output:
> Enumerating objects: 152755, done.
> Counting objects: 100% (152755/152755), done.
> Delta compression using up to 16 threads
> Compressing objects: 100% (70481/70481), done.
> Writing objects: 100% (152755/152755), done.
> Total 152755 (delta 83181), reused 150956 (delta 81540), pack-reused 0
> fatal: could not find pack <packfile.pack>
> fatal: failed to run repack
> Steps I have tried (mostly suggested by ChatGPT):
>    - Closing all programs with Git integrations
>    - Hunting down <packfile.pack>; it exists in .git/objects/pack and I 
>    have the permissions "Full control", "Modify", "Read & execute", "Read", 
>    and "Write" (though not "Special permissions")
>    - Running the command as administrator in case permissions were the 
>    issue
>    - Checking for file locks on the packfile
>    - Running `git fsck` on the repository
>    - Running `git gc --no-prune` for testing (still failed)
>    - Checking for Git updates
>    - Restarting my computer
> Googling (at my level of skill, anyway) isn't finding any help. What can I 
> do?
> Many thanks!
> Lyndon Gingerich

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To view this discussion on the web visit

Reply via email to