Tonight I did a bunch of tiny steps towards making the cache management
code behave more like a library.  There are no longer any global variables
in read-cache.c.  Nothing ever uses more than one cache yet, but I can
see how it might simplify some of the merge code.

They're also visible here:

[PATCH 01/19] write_cache api signature change, isolate active_cache and 
active_nr inside read-cache.c
[PATCH 02/19] Add new api's to front the active_cache and active_nr cache 
[PATCH 03/19] convert show-diff.c to use new cache hiding api's
[PATCH 04/19] Migrate update-cache.c to use the new cache api's
[PATCH 05/19] migrate checkout-cache.c to the new cache api's
[PATCH 06/19] migrate show-files.c to the new cache api's
[PATCH 07/19] migrate merge-cache.c over to the new cache api's
[PATCH 08/19] rename remove_entry_at to remove_cache_entry_at and expose as a 
public api
[PATCH 09/19] migrate read-tree.c to the new cache api's
[PATCH 10/19] migrate check-files.c to the new cache api's
[PATCH 11/19] migrate write-tree.c to use the new cache api's
[PATCH 12/19] fix up diff-cache.c to use new cache api's
[PATCH 13/19] Remove active_cache, active_nr, and active_alloc from public view
[PATCH 14/19] move cache_header out of the public view
[PATCH 15/19] introduce a cache struct and move the various cache globals into 
[PATCH 16/19] change all call sites that use the return value of read_cache to 
get the # of cache entries.
[PATCH 17/19] temporarily change add_cache_entry to create an empty cache on 
[PATCH 18/19] rename cache_match_stat to ce_match_stat to match other 
cache_entry related functions/macros
[PATCH 19/19] the end goal of the last dozen or so commits, there's no longer a 
global cache variable

[PATCH 01-19/19] All of the above combined
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at

Reply via email to