This patch implements a small tidy up of rev-list.c to reduce
(but not eliminate) the amount of ugliness associated
with the merge_order flag.

Signed-off-by: Jon Seymour <[EMAIL PROTECTED]>
---
Linus: I decided not to abstract this out as a function
as _too_ much abstraction can be a bad thing from a
readability point of view. Let me know if you disagree.
---

 rev-list.c |   10 +++-------
 1 files changed, 3 insertions(+), 7 deletions(-)

34a034b978c6b946fafdf41b42c5f67ee9c94599
diff --git a/rev-list.c b/rev-list.c
--- a/rev-list.c
+++ b/rev-list.c
@@ -78,19 +78,15 @@ static void show_commit(struct commit *c
 
 static int filter_commit(struct commit * commit)
 {
-       if (merge_order && stop_traversal && commit->object.flags & BOUNDARY)
+       if (stop_traversal && (commit->object.flags & BOUNDARY))
                return STOP;
        if (commit->object.flags & (UNINTERESTING|SHOWN))
                return CONTINUE;
        if (min_age != -1 && (commit->date > min_age))
                return CONTINUE;
        if (max_age != -1 && (commit->date < max_age)) {
-               if (!merge_order)
-                       return STOP;
-               else {
-                       stop_traversal = 1;
-                       return CONTINUE;
-               }
+               stop_traversal=1;
+               return merge_order?CONTINUE:STOP;
        }
        if (max_count != -1 && !max_count--)
                return STOP;
------------
-
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to