Just tried starting again on my local machine because when I tried pushing,
git said that it local was also set to bare init.  When I looked this was
the case.  Silly me.  

So I deleted on my local and added a single file and when I try pushing this
I get the following:
 ! [rejected]        master -> master (non-fast-forward)
error: failed to push some refs to 'paul@localhost:/Users/paul/<prject>'
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Merge the remote changes (e.g. 'git pull')
hint: before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.

When I try and pull I then get the following:
fatal: No remote repository specified.  Please, specify either a URL or a
remote name from which new revisions should be fetched.

I then addded my repo with the following command, but  this is the wrong
git pull --repo=<project>

What the hell am I doing wrong???

View this message in context: 
Sent from the git mailing list archive at Nabble.com.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to