Am 24.07.2012 21:01, schrieb Justin Spahr-Summers:
> This occurs on Mac OS X 10.7.4, on git versions (Apple Git-33) and 
> Steps:
>  1. Create or clone a repository to an absolute path that contains spaces.
>  2. Add a submodule to the repository, if it does not already have one.
>  3. Within that submodule, attempt to add another submodule.
> The result is an error "fatal: Not a git repository", followed by the 
> relative path to the submodule directory within .git/modules of the top-level 
> repository.
> Similarly, using "git submodule update --init --recursive" in a 
> freshly-cloned repository that matches the above configuration will fail with 
> the same error. "git clone --recursive" does not seem to suffer from the same 
> problem at clone time, but will still fail to add recursive submodules.

Hmm, I don't understand how that is different from what t7407 does, it uses
"git submodule update --init --recursive" in to populate recursive submodules
in a freshly cloned repository whose path contains a space (in the trash
directory name) in test number 8.

Does the git test suite succeed for you?
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to