On Tue, Aug 21, 2012 at 10:24 AM, Jeff King <p...@peff.net> wrote:
>> I ran into this problem when I had a BSOD during a rebase (ignore that
>> I'm having to use Windows). This meant that only half of the hash got
>> written into HEAD and all git commands I tried failed.
> That generally shouldn't happen, as we write new ref content to a
> temporary file and then rename it into place atomically. I wonder if
> there is a problem with the atomicity there (we do not fsync after
> close, which some filesystems might want), or if it was simply
> filesystem corruption related to your BSOD.

It's a truecrypt drive and I had to run diskcheck on the drive
(because of bad unmounting). In essence the file could have been
invalid and just restored it to some invalid usable state. Also it
might be truecrypt atomicity problem.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to