Jeff King <p...@peff.net> writes:
> Yeah, I agree that "refnames" would be better. I think something like
> "spec" or "refspec" would indicate better that they are to be matched
> against, but then you run afoul of confusing that with colon-delimited
> refspecs (which I do not think fetch-pack understands at all).
Correct. It only takes the LHS of the refspecs, following the "one
tool does one specific thing" philosophy. The arrangement was that
the calling script interpreted refspecs, split them into LHS and
RHS, fed the LHS of the refspecs to fetch-pack, and then read the
output to learn which local refs (i.e. RHS of the refspecs) to
update with what value.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html