On Wed, Sep 5, 2012 at 12:23 AM, Junio C Hamano <gits...@pobox.com> wrote:
> Nguyen Thai Ngoc Duy <pclo...@gmail.com> writes:
>> On Sun, Sep 2, 2012 at 7:12 AM, Adam Spiers <g...@adamspiers.org> wrote:
>>> extern void path_exclude_check_init(struct path_exclude_check *, struct
>>> dir_struct *);
>>> extern void path_exclude_check_clear(struct path_exclude_check *);
>>> +extern struct exclude *path_excluded_1(struct path_exclude_check *, const
>>> char *,
>>> + int namelen, int *dtype);
>>> extern int path_excluded(struct path_exclude_check *, const char *, int
>>> namelen, int *dtype);
>> Exported functions should have nicer names than *_1. No idea what are
>> better names though, maybe exclude_path?
> Which part is better?
> Just like between path_excluded_1() and path_excluded() nobody can
> tell how they differ (except perhaps the former smells more special
> purpose thanks to its funny name) and wouldn't be able to tell which
> one to call without looking at their sources, it is hard to tell
> path_excluded() and exclude_path() apart. In a sense, that pair is
> even worse as there is no hint to suggest which one is more exotic
> between them in their names.
We could introduce exclude_path() and kill path_excluded() then. There
are just about 5-6 call sites to replace.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html