Am 28.09.2012 10:35, schrieb Frans Klaver:
> Hi,
> Please remember to reply to all when discussing things on the git mailing 
> list.
> On Fri, Sep 28, 2012 at 10:29 AM, Angelo Borsotti
> <> wrote:
>> Hello
>> I apologise for having used the wrong script to reproduce the error.
>> This is  the right one:
>> angelo@ANGELO-PC /d/gtest (master)
>> $ mkdir remote.git
>> angelo@ANGELO-PC /d/gtest (master)
>> $ cd remote.git
>> angelo@ANGELO-PC /d/gtest/remote.git (master)
>> $ git init --bare
>> Initialized empty Git repository in d:/gtest/remote.git/
>> Now with the git gui I try to open the d:/gtest/remote.git/ and
>> receive the message
>> that it is not a git repository.
>> I understand that the gui is mostly aimed to non-bare repositories,
>> but in such a case
>> it would be better it could give me a message like, e.g. "could not
>> open a bare repository"
>> instead of telling me that it is not a git repository (I thought my
>> bare repository was
>> corrupt, and tried to figure out what was wrong with it).
> Actually git-gui 0.16.0 is telling me that it cannot use bare
> repositories, much in the vein of what I wrote earlier. Don't know if
> it matters that I'm on Linux though.

I get "Not a Git repository: remote.git" as well, when I run
git gui "somewhere" (i.e. not in "remote.git") and the select 
"Open Existing Repository".

I get "Cannot use bare repository: .../remote.git" when I run git gui
from inside the "remote.git" directory.

Both on WinXP with msysGit.

/dev/random says: Unless you're the lead dog, the view never changes.
python -c "print 
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to