I forgot to say that all of the config settings
are not changed from the default.


On 10/4/12 11:16 AM, John Whitney wrote:

Thanks for checking this on your machine.

This problem occurs on Mac, Windows, and Linux, and
with multiple versions of git. Note that in my script a CR
is appended to test.txt. On the Mac, you can generate this
in Terminal by pressing Ctrl-V Ctrl-M. Or, alternatively,
just download and run the script like this: "sh"


On 10/4/12 10:21 AM, Andrew Wong wrote:
On 10/04/2012 12:35 AM, John Whitney wrote:
I just ran into a problem that I'm pretty sure is a bug in git. Just read and run this (fairly trivial) shell script to replicate.
I tried your steps on a Mac, but I wasn't able to produce the issue. Perhaps I don't have the right CRLF configs to trigger the issue. I've tried it on v1.7.9.6, which came with Xcode, and v1.7.7. What git version are you using? And, if any, what are your configs for "core.eol", "core.safecrlf", and "core.autocrlf" ?

What Phil said also makes sense though.

Great support for great users! Please visit for 
our support policies, instructions and FAQs.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to