Jacob Keller <jacob.kel...@gmail.com> writes:
>>>> If we were to change those, we could discuss if we want to go with
>>>> full sentences
>>>> all the time:
>>>> submodule is new
>>>> submodule is deleted
>>>> submodule is not initialized
>>> I agree, I'll make a new patch that does this as a cleanup prior to
>>> this re-work.
> Sorry for being unclear myself, too. I'm keeping it as "not
> initialized" and updating the description of the patch that changed it
> from "not checked out" to "not initialized"
Whether it is done inside or outside the scope of this series, the
other two "is new"/"is deleted" updates look very sensible ones to
make in the longer run. I'd further suggest to unify "commits not
present" and "revision walker failed" into one error class. From
the end user's point of view, they aren't very different.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html