-----Original Message-----
From: Philip Oakley [mailto:philipoak...@iee.org] 

>Have you tried `git ls-remote` ?
>The `branch -r` just lists the local 'rtb's (IIUC).

Nice, I didn't know about that command - I tried it though and it does list the 
remote branches correctly. I checked the commit refs given and it tallies with 
the refs at the gitolite server end.

>It could be someone has accidently pruned or deleted that branch at the remote.

I don't think so, as I say it's a gitolite server, so usually nobody is on it. 
We just push to it and set up post-receive hooks for if updates need to be 
pushed on to a deployment server.

Do you know of ways to check if anything is corrupted within the repo? I ran 
git fsck, but that didn't show up anything.

>What version are you (they) on?

1.9.1 at both ends (my laptop and our gitolite server)

> Gmane had to quit. Try http://public-inbox.org/git (see the help link)

Ah! Thanks. I tried searching but so far only turned up this thread.

> philip 

Thanks for your reply, Philip.


Reply via email to