On Fri, Sep 30, 2016 at 12:19:51PM -0700, Junio C Hamano wrote:
> Jeff King <p...@peff.net> writes:
> > ... Now that function _would_
> > want to be updated as a result of the other conversation (it would need
> > to do something sensible with "-1", like turning it into "7", or
> > whatever else is deemed reasonable outside of a repository).
> > Anyway. I just wonder if you want to give it a better name while you are
> > at it.
> I'd say the patch to introduce the new function that makes the old
> name potentially confusing is a good one to do the rename. Until
> then I do not think there is no need to rename the existing one ;-)
I guess my point was that the poor name may have contributed to the need
to explain it. But I'm happy to deal with it in my series (I also
updated it to use "struct oid"; I'll probably rebase mine on top of your
comment to save you dealing with the nasty merge).
> Related tangent about "like turning it into", I am thinking adding
> something like this as a preparatory step to Linus's auto-sizing
> serires. That way, we do not have to spell "7"
> -- >8 --
> Subject: abbrev: add FALLBACK_DEFAULT_ABBREV to prepare for auto sizing
Yep, looks like a good idea.