On Wed, Aug 9, 2017 at 5:01 AM, Jeff King <p...@peff.net> wrote:
> As discussed in the previous commit, Git is not well-tested
> with old versions of curl (and in fact since v2.12.0 does
> not even compile with versions older than 7.19.4). Let's
> stop pretending we support curl that old and drop any
> now-obslete #ifdefs.
>
> Choosing 7.16.0 is a somewhat arbitrary cutoff, but:
>
>   1. it came out in October of 2006, over 10 years ago.
>      Besides being a nice round number, it's a common
>      end-of-life support period, even for conservative
>      distributions.
>
>   2. that version introduced the curl_multi interface, which
>      gives us a lot of bang for the buck in removing #ifdefs
>
> Signed-off-by: Jeff King <p...@peff.net>
> ---
>  Documentation/config.txt |  3 +--
>  http-push.c              | 23 --------------------
>  http-walker.c            | 12 -----------
>  http.c                   | 56 
> +-----------------------------------------------
>  http.h                   | 20 +----------------
>  remote-curl.c            |  4 ----
>  6 files changed, 3 insertions(+), 115 deletions(-)

`git grep USE_CURL_MULTI` also yields
Documentation/config.txt
t/t5540-http-push-webdav.sh

Would these also need adaption in this patch?

Reply via email to