On Wed, Feb 14, 2018 at 10:35 PM, SZEDER Gábor <szeder....@gmail.com> wrote:
>> +__gitcomp_builtin ()
> Please excuse the bikeshed at v3, but I don't like the name of this
> function.  It indicates that it completes builtins, but it completes
> options of builtins, and even then only the options of those using parse
> options.  Furthermore, the '__gitcomp' prefix is usually used for
> functions that merely put words into COMPREPLY, but this function does a
> whole lot more (getting the options from builtins, include and exclude
> options, caching).
> Alas I don't have any great name; __git_complete_options is better,
> because it uses the right function name prefix, but only slightly
> better, because it can't generally be used to complete options, as it
> won't work with scripts or with builtins not using parse options (though
> with time more scripts will be turned into builtins and more builtins
> will use parse options).  I'm not sure it's that match better to make it
> worth changing fourty-odd patches.

Since it's still on 'pu', renaming is still an option. I don't mind
renaming (and I'll need to check every patch anyway when I make
--rerere-autoupdate completable). Say "do" and I will.

Reply via email to