On Sun, Jan 20, 2013 at 11:28 AM, John Keeping <j...@keeping.me.uk> wrote:
> On Sun, Jan 20, 2013 at 10:54:52AM -0800, Junio C Hamano wrote:
>> John Keeping <j...@keeping.me.uk> writes:
>>> git-p4 supports Python 2.6 and later versions of Python 2.  Since Python
>>> 2.8 will never exist [1], it is most concise to just list the supported
>>> versions.
>> Thanks; Eric's patch recently updated git-p4.py to require 2.4 I
>> think. Shouldn't it also be updated?

Actually, the script does not support python 2.4 in its current state
since it uses subprocess.check_call which was introduced in python

But, this can be trivially worked around.  I made the changes in my
own tree on Friday and planned to submit them after using it myself
for a few days.

Personally, I prefer to continue to provide the ability to compile and
install a fully working git on platforms in common use without pulling
in additional dependencies.  At least while it's fairly easy to do so.
 So, in my opinion, git-p4 should be patched to support python 2.4 and
the comment in INSTALL should be updated.  But, this opinion should be
taken with the appropriate grain of salt since I'm not really a
contributor to any of the python infrastructure.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to