I've a readonly git repository that I'm hosting via HTTP (a bare git repository 
located within the appropriate directory on the server). I push to it via my 
own SSH account (local repository with a remote pointing to the ssh:// URL).

This has all worked fine so far - I push via ssh, and others can clone and pull 
via the HTTP URL.

I've recently added a branch - "beta" - which pushed just fine, but now cloning 
via the HTTP URL doesn't seem to show the new branch - just master:

$ git clone http://server.tld/path/to/repository.git repository
Cloning into 'repository'...
$ cd repository
$ git branch -a
* master
  remotes/origin/HEAD -> origin/master

Cloning via the readwrite ssh URL works fine though:

$ git clone ssh://u...@server.tld:www/path/to/repository.git repository
Cloning into 'repository'...
stdin: is not a tty
remote: Counting objects: 225, done.
remote: Compressing objects: 100% (196/196), done.
remote: Total 225 (delta 109), reused 77 (delta 25)
Receiving objects: 100% (225/225), 9.55 MiB | 295 KiB/s, done.
Resolving deltas: 100% (109/109), done.
$ cd repository
$ git branch -a
* master
  remotes/origin/HEAD -> origin/master

I've tried 'git clone --mirror' just in case, but this just resulted in a bare 
repository with only the 'master' branch, still.

Anyone have any ideas about what I'm doing wrong?


To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to