Johannes Schindelin <johannes.schinde...@gmx.de> writes: > On Wed, 9 Oct 2019, Junio C Hamano wrote: > >> Johannes Schindelin <johannes.schinde...@gmx.de> writes: >> >> > FWIW I actually agree with Junio about the helper, but in hindsight I >> > could have used a better name (not one that is tied to the "index"). >> > Something like `unsigned_one_complement()`. But of course, that would >> > say _what_ it does, not _why_. >> >> I personally feel that the particular name is on the better side of >> the borderline. "st_add3(a, b, c)" says it is about adding three >> size_t quantities, without saying why it exists and should be used >> over a+b+c. Existence of the helper and calling it alone should be >> a good enough sign that we somehow feel a+b+c is not sufficient [ly >> safe], so we do not call it st_add3_safe() or st_add3_wo_overflow(). >> >> Your unsigned-one-complement would fall into the same category, no? > > Yes. That's what I meant to say with the "what vs why" argument.
And what I wanted to say was that, even though we encourage use of names that convey _why_, in a case like this, the name that conveys only what without explicitly saying why is probably OK.