On Thu, Mar 14, 2013 at 12:39 PM, Timo Sand <timo.j.s...@gmail.com> wrote:
> Hi
> I tried to open a website by runnin 'git web--browse http://google.com'
> and it replied 'No known browser available'.

First git web--browse is a plumbing shell script to display
documentation on a web browser when you type something like "git help
-w log".
It is not really supposed to be used directly by the user. On OS X it
might be simpler to just type "open http://google.com";.

That said there is the following in it to make it work on OS X:

# SECURITYSESSIONID indicates an OS X GUI login session
-o "$TERM_PROGRAM" = "Apple_Terminal" ; then
browser_candidates="open $browser_candidates"

So I guess that you don't have SECURITYSESSIONID set in your terminal
and you are not using Apple Terminal.

As I am not using OS X, I have no idea how to improve the script in this case.

> I also tried with '--browser=chrome' and '--browser=google-chrome' but
> the responded with 'The browser chrome is not available as 'chrome'.'

Could you try something like: "chromium http://google.com"; or
"chromium-browser http://google.com";
If it works, then using 'git web--browse' with '--browser=chromium' or
'--browser=chromium-browser' should work.

Otherwise did you try "chrome http://google.com"; and "google-chrome

> I expected the command to open a new tab in my browser in each of the 3 tries.
> This has worked for my system before.
> OS X 10.8.2, git 1.8.2, Google Chrome 27.0.1438.7 dev

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to