From: Thomas Rast <tr...@inf.ethz.ch>
Almost the same as last time. Changed: the rename suggested by Junio
> The only little concern I may have is this cmp_* function tells us
> "I found it!" by returning true, which is counter-intuitive to the
> readers of the caller (not the callee).
> I think it makes sense to compare delta-base-cache entries only for
> equality, so eq-delta-base-cache-entry might be a better name for
> it, perhaps?
and a small reword to patch 3's commit message to make it clearer at
which stage we unpack the deltas.
Thomas Rast (3):
sha1_file: remove recursion in packed_object_info
Refactor parts of in_delta_base_cache/cache_or_unpack_entry
sha1_file: remove recursion in unpack_entry
sha1_file.c | 411 +++++++++++++++++++++++++++++++++++++++---------------------
1 file changed, 266 insertions(+), 145 deletions(-)
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html