I'm having an error in "contrib/remote-helpers/test-hg.sh" and it
reproduces on every version I tested since you implemented it. Is it
something in my environment that would make it wrong ?

Cheers,
Antoine

---
expecting success:
  test_when_finished "rm -rf gitrepo*" &&

  (
  cd hgrepo &&
  hg update -r 0
  ) &&

  git clone "hg::$PWD/hgrepo" gitrepo &&
  check gitrepo zero master

1 files updated, 0 files merged, 0 files removed, 0 files unresolved
Cloning into 'gitrepo'...
--- expected 2013-04-01 21:46:32.086796549 +0000
+++ actual 2013-04-01 21:46:32.086796549 +0000
@@ -1,2 +1,2 @@
-zero
-refs/heads/master
+feature-a
+refs/heads/feature-a
not ok 4 - cloning with detached head

On Mon, Apr 1, 2013 at 11:14 PM, Felipe Contreras
<felipe.contre...@gmail.com> wrote:
> Hi,
>
> Here are a few fixes for the test framework on the remote-helpers.
>
> Felipe Contreras (3):
>   remote-helpers: fix the run of all tests
>   remote-bzr: remove stale check code for tests
>   remote-hg: fix hg-git test-case
>
>  contrib/remote-helpers/Makefile          |  1 +
>  contrib/remote-helpers/test-bzr.sh       | 14 --------------
>  contrib/remote-helpers/test-hg-hg-git.sh |  1 -
>  3 files changed, 1 insertion(+), 15 deletions(-)
>
> --
> 1.8.2
>
> --
> To unsubscribe from this list: send the line "unsubscribe git" in
> the body of a message to majord...@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to