On Fri, Apr 19, 2013 at 10:56:06AM +0200, Sebastian Schmidt wrote:

> I tried switching to smart http now, but have the same error, I guess I
> did something wrong. It seems like it is getting 401, but I also noticed
> that info/refs is just an empty file. This is the config of my apache2:
> SetEnv GIT_PROJECT_ROOT /crypt/git
> ScriptAlias /git/ /usr/lib/git

This should point to /usr/lib/git/git-http-backend, which I think is the
source of your problems.

> <Directory /crypt/git>
>       Allow from all
>       Order deny,allow
>       AuthType Basic
>       AuthName "Git global"
>       AuthUserFile /etc/apache2/auth/passwd
>       AuthGroupFile /etc/apache2/auth/groups
>       Require group git-shared
> </Directory>

I'm not sure this <Directory> match will do what you want, because from
Apache's perspective, it is hitting /usr/lib/git/git-http-backend on the
filesystem, and it is only git that actually touches the filesystem.

I think you want to use

  <Location /git>

instead. But I am not an Apache expert, so maybe it does work.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to