Hi,

I work on a case insensitive filesystem and I have core.ignorecase set to true. 
I have a series of troublesome commits and here is what git cat-file -p shows 
me:

...
100644 blob 99...       fourCircles.py
100644 blob 97...       fourcircles.py
...

The content of those slightly differ:

--- a/99...
+++ b/97...
-__version__='$Header: .../fourCircles.py, ...$'
+__version__='$Header: .../fourcircle.py, ...$'
 
As you can guess this git repo started its life with CVS (it was converted with 
git cvsimport). 
So I thought it was a job for git filter-branch, specifically I propose to do:
git filter-branch --index-filter 'git rm --cached --ignore-unmatch 
.../fourCircles.py' <commit>

However because of those two blobs, I have:

~> git status
#       modified:   .../fourCircles.py

and git filter-branch therefore refuses to run. I tried to use checkout, reset, 
even to commit that fluke of a change but whatever I do, that file is still 
marked 
as modified. 

I am sure I am missing a tiny detail that would get me
out of those dire straights but it has eluded me so far.

I run git 1.8.2.2 on MacOS 10.7.5 (installed with MacPorts if that matters).

Best wishes,

Luc J. Bourhis

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to