The "ret" was meant to mean "the return value we got from the
callback function", not "the return value we would give our caller".
This rename is a bit misleading in that "cb_bits == -1" does not
mean "full bits set", and it does not tell us much what these "bits"
They are used to answer this question: which one of the trees in
t[0..n] did the callback function consumed (hence needs their
So perhaps call it "trees_used" or something?
By the way, our log message usually do not Capitalize the subject
after the "<area>:", i.e. do something like this instead:
Subject: [PATCH 1/3] traverse_trees(): clarify return value of the callback
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html