Stefan Beller <> writes:

> On 08/12/2013 07:46 AM, Junio C Hamano wrote:
>> I think that is an overall improvement, especially if we also update
>> the checks of {one,two}->mode made for the block that deals with
>> submodules to use DIFF_FILE_VALID().
>> Thanks.
> So, do I understand your reasoning, when proposing this patch?

I meant the condition in the "if" statement, not the parameters to
show_submodule_summary().  There are checks on ->mode fields that
bypass the DIFF_FILE_VALID() macro, hurting readability.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to