On Fri, Sep 06, 2013 at 07:28:43PM +0200, Matthieu Moy wrote:
> >> FWIW, I had the same thought as Junio. I much prefer something like
> >> status.displayCommentPrefix for clarity and future-proofing.
> > Sounds fine, but I don't understand why we'd want this to be an option
> > with a future in the first place. Why not just fix the remaining bugs
> > before merging to master and make it unconditional?
> I think some old-time users may appreciate to have a
> backward-compatibility option. It doesn't cost much for us, as we need
> the variable internally (to use the prefix in COMMIT_EDITMSG, and not on
> stdout), and it actually makes it easier to test.
Exactly. I kind of prefer the old output, though it is probably just
having my brain rotted from seeing it so much. I'm going to give the new
behavior a try for a while to see if I adjust, but ultimately I'd like
to have the escape hatch. And as you say, it doesn't cost much, since we
have to keep both code paths anyway.
> I won't change the header part in this topic (no time, sorry), but the
> missing newline before "nothing added" actually sounds like a bug, as
> there is normally a newline after each list of file in `git status`,
> except untracked and ignored.
> I'll fix it as a separate patch in the next round.
Thanks for looking into it.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html