From: "Karsten Blees" <karsten.bl...@gmail.com>
However, defining the constants inversely is a bit unintuitive (i.e.
1.25 instead of 0.8, 6 instead of 0.166). Perhaps the thresholds
should also be calculated once on resize, not on every add / remove.
What about this:
#define HASHMAP_GROW_AT 80
#define HASHMAP_SHRINK_AT 16
mico-bikeshed adding a code comment...
#define HASHMAP_GROW_AT 80 /* percent */
#define HASHMAP_SHRINK_AT 16 /* percent */
map->grow_at = (unsigned int)((uint64_t) map->tablesize *
HASHMAP_GROW_AT / 100);
map->shrink_at = (unsigned int)((uint64_t) map->tablesize *
HASHMAP_SHRINK_AT / 100);
[No need to add to cc...]
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html