Christian Couder <chrisc...@tuxfamily.org> writes:
> Here is version 3 of a patch series to improve the way
> sha1_object_info_extended() behaves when it is passed a
> replaced object. The idea is to add a flags argument to it
> in the same way as what has been done to read_sha1_file().
Will take a look again (in the meantime, will queue on 'pu').
I do not think the new name for the bit is necessary nor it is a
good change, though. Given an object name, reading the data and
inspecting the metadata (i.e. type and size) should yield consistent
results, so the original name is a perfectly appropriate name that
means "use the replacement object when using read-sha1-file and
friends to ask about an object". The use of the replacement object
happens to be implmented via lookup-replace-object helper, but that
is an implementation detail of _how_ it is done, not the high level
descroption of _what_ the callers want to see done.
But that is just a minor nit.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html