Jonathan Nieder wrote:
Erez Zilber wrote:

Writing perl.mak for Git Writing perl.mak for Git rename MakeMaker.tmp => perl.mak: No such file or directory at /usr/share/perl5/ExtUtils/MakeMaker.pm line 1024. make[3]: perl.mak: No such file or directory make[3]: perl.mak: No such file or directory make[3]: *** No rule to make target `perl.mak'. Stop.

Looks like MakeMaker is racing against itself. Alas, (on a fairly current Debian system, with perl 5.14.2) I'm not able to reproduce that.

Instead, I get this:

| $ make -j8 rpm [...] | make[2]: Leaving directory `$HOME/rpmbuild/BUILD/git-' | make[1]: Leaving directory `$HOME/rpmbuild/BUILD/git-' | + exit 0 | Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.WqNYnx | + umask 022 | + cd $HOME/rpmbuild/BUILD | + cd git- | + rm -rf $HOME/rpmbuild/BUILDROOT/git- | + make -j12 'CFLAGS=-O2 -g' \ DESTDIR=$HOME/rpmbuild/BUILDROOT/git- \ ETC_GITCONFIG=/etc/gitconfig prefix=/usr \ mandir=/usr/share/man htmldir=/usr/share/doc/git- \ INSTALLDIRS=vendor install install-doc | make[1]: Entering directory `$HOME/rpmbuild/BUILD/git-' | make[1]: warning: -jN forced in submake: disabling jobserver mode. | make[1]: *** write jobserver: Bad file descriptor. Stop. | make[1]: *** Waiting for unfinished jobs.... | make[1]: *** write jobserver: Bad file descriptor. Stop. | error: Bad exit status from /var/tmp/rpm-tmp.WqNYnx (%install) | | | RPM build errors: | Bad exit status from /var/tmp/rpm-tmp.WqNYnx (%install) | make: *** [rpm] Error 1

Known problem?  A build without -j8 gets further.

It seems like it's not a problem with el6 or git's Makefiles themselves. I haven't used the spec file from git.git in ages, but I have tried to ensure that the one we use in Fedora builds cleanly on el{5,6}. I use this myself to keep an update git on el6, where Red Hat has left git at 1.7.1 since the release of el6 however many years ago. :(

Here's a build I ran just now using the latest Fedora SRPM, showing it succeeds with make -j5:


The build task, with all of the resulting rpms and logs is here:


(That will remain for a few days or so, at least. Scratch builds like this aren't kept indefinitely.)

This makes me think that there's something in the git.spec in git.git that differs from what we use in Fedora/EPEL. I don't have time to dig into that now, but perhaps someone with time and inclination can diff the spec files and find the cause.

I know the Fedora/EPEL spec file and what's in git.git have grown apart a good bit, unfortunately. That's the cost of having a spec file that is meant to work across a very wide array of RPM-based systems, I guess. The Fedora/EPEL spec file is fairly specific to the Fedora/EPEL build tools (mock is the primary build tool).

Hope this helps a little in narrowing down the issue. I'm sorry I can't be of more assistance at the moment.

Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
How am I supposed to hallucinate with all these swirling colors
distracting me?
    -- Lisa Simpson

Attachment: pgpOrbVEb8OdK.pgp
Description: PGP signature

Reply via email to