In order to set up automated builds and tests of the CMake toolchain 
( on HP-UX 11.11 (hppa) and 11.23 (ia64), I needed to install git 
on those platforms.
The latest binary package available from is version, which I installed with all of its dependencies.
When trying to set up the CMake build, I ran into the first problem:

$ git pull origin
error: cannot create thread: Function is not available
fatal: fetch-pack: unable to fork off sideband demultiplexer

So I examined the git source package and found that the author of the HP-UX 
port forgot to set


in config.mak.autogen to enable threading. I added this setting and rebuilt 
git. On 11.23, everything was fine now - no further issues.
On 11.11 though, git now crashed with a Bus Error. Some debugging showed that 
this was due to a multithreading issue - obviously some dependency library has 
not been built as reentrant code. To fix this, I disabled threading by setting


in config.mak.autogen and rebuilt git again. After that, "git pull" and "git 
fetch" worked correctly and I could proceed to set up the CMake build and test.
Alas, the CMake tests include a test case "CTest.UpdateGIT" that creates a git 
repository, creates a submodule, imports some content and attempts to check out 
a revision. At that point, the command

git submodule init

fails with the output

    Assertion failed: err == REG_ESPACE, file compat/regex/regexec.c, line 1096
    No submodule mapping found in .gitmodules for path 'module'

and the stacktrace of the resulting core dump is

#0  0xc020ced0 in kill+0x10 () from /usr/lib/libc.2
#1  0xc01a7f84 in raise+0x24 () from /usr/lib/libc.2
#2  0xc01e9308 in abort_C+0x160 () from /usr/lib/libc.2
#3  0xc01e9364 in abort+0x1c () from /usr/lib/libc.2
#4  0xc0176998 in _assert+0x178 () from /usr/lib/libc.2
#5  0x205fa0 in check_matching+0x290 ()
#6  0x2053b8 in re_search_internal+0x128 ()
#7  0x204ac0 in regexec+0xc8 ()
#8  0x4da40 in collect_config+0x60 ()
#9  0x108b30 in get_value+0xd8 ()
#10 0x108efc in git_parse_source+0x1bc ()
#11 0x10ac70 in do_config_from+0x70 ()
#12 0x10ad3c in git_config_from_file+0x8c ()
#13 0x10b274 in git_config_with_options+0x84 ()
#14 0x4dd6c in get_value+0x224 ()
#15 0x4eed4 in cmd_config+0x744 ()
#16 0x17150 in run_builtin+0x110 ()
#17 0x1739c in handle_internal_command+0xcc ()
#18 0x174fc in run_argv+0x2c ()
#19 0x17724 in main+0x194 ()

Since I'm no git expert (I'm not even a regular git user in fact), there's 
nothing left for me to do except asking for help...
Please CC me (gerhard dot grimm at detec dot com) with any replies since I'm 
not subscribed to the list. Thank you!

Best regards,

This e-mail message has been scanned and cleared by Postini / Google Message 
Security and the UNICOM Global security systems. This message is for the named 
person's use only. If you receive this message in error, please delete it and 
notify the sender. 

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to