----- Original Message ----- From: "Dieter Komendera" <die...@komendera.com>
To: <git@vger.kernel.org>
Sent: Monday, March 31, 2014 10:04 PM
Subject: Bug report: git add . -p "Argument list too long"

Hi there,

since a while when I want to stage diffs in one of my big repos with "git add . -p” I get this error:

Can't exec "git": Argument list too long at /usr/local/Cellar/git/1.9.1/libexec/git-core/git-add--interactive line 180. Died at /usr/local/Cellar/git/1.9.1/libexec/git-core/git-add--interactive line 180.

Mac OS X 10.9.2
git 1.9.1 (installed via homebrew)

I’ve also tried the latest versions of the 1.7 and 1.8 branches which also yielded the same error in that repo. git add . -p works fine in other (smaller) repos. Unfortunately I’m not able to share this private repo.

I found this rather old posting in the mailing list archive, unfortunately the link to the "quick and easy fix” looks dead:

Anybody can help?


http://article.gmane.org/gmane.comp.version-control.git/136157 maybe?
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to