> brian m. carlson wrote:
>> I'd like to introduce a set of preprocessor constants that we'd use
>> instead of hard-coded 20s and 40s everywhere.
I agree that it would help code clarity to have symbolic constants for
On 04/19/2014 12:40 AM, Jonathan Nieder wrote:
> Lukewarm on that. It's hard to do consistently and unless they're
> named well it can be harder to know what something like
> BINARY_OBJECT_NAME_LENGTH means than plain '20' when first reading.
OK, so let's see if we can name them well. (Though I think if the names
come into wide use then we'll get familiar with them quickly.)
libgit2 seems to use the name "oid" (for "object ID") where we tend to
use "sha1" or "name". That might be a good convention for us to move
Their constants are called GIT_OID_RAWSZ (== 20) and GIT_OID_HEXSZ (==
40). They don't exactly roll off the tongue, I'll admit.
We wouldn't need a "GIT_" prefix, I think, since our code is not meant
to be used as a library.
Let the brainstorming (and bikeshedding) begin!
1. GIT_OID_RAWSZ / GIT_OID_HEXSZ
2. OID_RAWSZ / OID_HEXSZ
3. OID_BINARY_LEN / OID_ASCII_LEN
4. BINARY_OID_LEN / ASCII_OID_LEN
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html