On Fri, May 30, 2014 at 02:03:56AM +0200, f...@fuz.su wrote:

> I've tried to changing the URL of a remote temporarily because of network
> issues. I tried something like this:
>     git -c remote.foo.url=http://gitserver.example/repo.git push foo bar
> Tracing shows that git push does not use the provided URL for the remote foo
> and instead uses the URL configured in the repository configuration as if the
> -c option was not present at all. This looks like a bug to me.

You are correct that this won't work, but the reason is a bit

The remote.*.url config field is actually a "multivar", meaning that you
can specify it multiple times. In that case, "git push" will push to
each configured URL in order in which they appear in the config.

In the command above you are not overwriting remote.foo.url, but rather
adding an extra value to it. So we first try to push to the remote
defined in your actual config, and then to the one on the command-line.
You can see this in action like:

  $ git init --bare /tmp/foo
  $ git init --bare /tmp/bar
  $ git remote add foo /tmp/foo
  $ git -c remote.foo.url=/tmp/bar push foo HEAD

You should see pushes to both /tmp/foo and /tmp/bar.

Config multivars like this are rather hard to work with, as there is no
way to say "reset the multivar to empty, _then_ add this new value". So
there isn't a simple solution using remote.*.url from the command-line
like this.

Another way of doing what you want is to use url.*.insteadOf, like:

   git -c url./tmp/bar.insteadof=/tmp/foo push foo HEAD

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to