Karsten Blees <karsten.bl...@gmail.com> writes:

> Right, it makes no sense for trace_performance(), and for
> trace_performance_since() only if followed by another 'measured' code
> section. In that special case, I think it wouldn't hurt if you had to
> write:
>
>   uint64_t start = getnanotime();
>   /* first code section to measure */
>   trace_performance_since(start, "first foobar");
>
>   start = getnanotime();
>   /* second code section to measure */
>   trace_performance_since(start, "second foobar");
>
> So I guess I'll drop the return value (and the second example, which
> is then redundant to the first).

That also sounds OK to me.

>>> +static void trace_performance_vfl(const char *file, int line,
>>> +                                 uint64_t nanos, const char *format,
>>> +                                 va_list ap)
>>> +{
>> 
>> Just being curious, but what does "v" stand for?
>> 
>
> trace_performance_vfl(, va_list)
> vs.
> trace_performance_fl(, ...)
>
> Will change to trace_performance_vprintf_fl()

Ah, OK.  The name with 'vprintf' in it does sound better.

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to